Development for phpBB 3.1

Closed beta for 3.1/3.2 available

phpBB 3.1 was released some weeks ago and the number of available extension is currently very week. But nevertheless the development for this great new version is important. You can now change main functionality without editing the style files. This makes it so much easier for me (as developer) to make the theme compatible with nearly every extension. The compatibility of ComBoot with automod was not given in the past, caused by bootstrap according to its css structure. Now that isn’t a big deal anymore.

I know a few of you already use phpBB 3.1 and also want to have a ComBoot version that works with it. Since phpBB 3.1 includes such high rate of file changes, I have to change almost every ComBoot included file. That simple means:
The development will took some (more) time.

You should also know, that the theme does already work with phpBB3.1, but it does simple not support any of the new features yet, so its not useful to use it, until every file has been rewritten. And that’s the reason, I will not offer a unstable release. So the first version you will probably be able to download may be a beta, but nothing earlier.

Additionally here are some information, what is also planned in the future for the phpBB3.1 version:

  • A extension for phpBB3.1 which will allow admins to easily change settings
  • A bunch of subthemes, which will allow to switch between completely different styles based on ComBoot (this will be a premium feature)
  • You have also an idea, what should be included next? Then tell me 🙂

Also notice, that if the version for phpBB3.1 will be released, there will be probably no more features added in the version for 3.0.x. It just takes to much time to maintenance both version. But you can still download the current theme then of course.

If you want to have a early look at the current theme, you can view it on the demo page. And at least here are some preview images of the new version, showing new features:

More images coming soon!